3.0.x - can't register with existing key