have you unchecked "Favicon" as a removal option?