Do you have MAC address filtering enabled on your router?