for Safari Cookies,

try reinstalling, and do a custom install,
make sure SIMBL is checked.

restart Safari.
load up a url (important)
then open Safari's preferences.
you will see a cookie icon, that is Safari Cookies preferences.
(you may need to click the 2 small arrows at the right of the preferences window to see it)