Sorry for the delay, just saw this now

all you need to do is open:
Applications/Utilities/Keychain Access.app

search for “Invisible”

double click - to open the info window.
look on the “Attributes” tab
click the “Show Password” checkbox

Thank you very much!!