Since update to Safari 13 Cookie 6 not recognizing "Full disk Access"

  • Hi,
    Had everything working fine with Cookie 6 but following the safari 13 update I am stuck at the selecting folder for access screen. Rebooted but did not fix. Any ideas would be much appreciated!

  • Cookie6 relies on the existence of Safari's cookie file to know if it has Full Disk Access:

    so, you should make sure that you run Safari NOT in Private Browsing mode, at least once to generate the file

  • The folder is there when I look in Finder BUT when the window "cookie needs to access this path to continue" opens I cannot see the library folder.

    I think its hidden to cookie, but its visible in Finder

    I am using Safari 13 BTW.

    I can drag the cookie folder, via finder, to the cookie window and the directory "Cookies.binarycookies" appears but then I can't select it.

    Any ideas please


  • try a full reset ofCookie, by deleting this folder:

  • Just tried that. When cookie boots up and goes to the screen to 'allow access' it gets to library/preferences and then I select it (allow) and 'allow' does not appear in the window
    next to library/preferences. All others appear OK

  • For me, this problem was related to remnants of Cookie 5. Once I got rid of those, everything worked as promised.
    FYI, this is what I had to do:

    • Drag Cookie 6 to AppCleaner.
    • Reinstall Cookie 5, then drag Cookie 5 to AppCleaner
    • Delete anything related to Cookie 5 that didn’t get uninstalled in Containers folder and Applications Scripts folder
    • Empty the trash
    • Reinstall Cookie 6
    • AVOID option to import Cookie 5 settings
    • Allow Global File Access
      Then the Enable Safari browser function worked and I’m able to get to the cookie window.