Cookie 6 not recognizing "Full disk Access"



  • Just started Cookie 6
    I am registered, activated and all

    I gave Cookie ( which is Cookie 6 ) Full disk access in system prefrences

    It still not recognized it has full disk access, and keeps asking to enable it

    I am stuck



  • Exactly same issue here!



  • Exactly the same problem here.



  • Same problem here on Mojave, solved by restarting. Once I did that, Safari was accepted and enabled.



    • Make sure you move Cookie 5 to the trash,
    • then try to remove/re-add Cookie to System Preferences
    • lastly, restart your computer


  • after giving Cookie 6 'full access' had to reboot my computer to get Safari accepted (not just restart Cookie)



  • Similar issues here. Firefox and Chrome got added with no problem, but Safari kept asking me to grant full disk access no matter how many times I did so. I restarted as LEoM suggested. Clicking for Safari access then produced a prolonged spinning beachball, but one that did resolve itself and it seems to be working now.



  • for everyone still with issues,
    here is the nuclear option, which may help:

    A full reset:

    • Move Cookie 5 to the trash
    • Export your favourites using the small heart icon in the bottom right of the “Websites” tab
    • Quit Cookie
    • Remove Cookie, and Cookie 5 from System Preferences (Full Disk Access)
    • Delete this folder: ~/Library/Contaniers/com.sweetpproductions.cookieapp
    • Restart your computer
    • Then open Cookie,and run through the setup again.
    • import your favorites back in using the same heart icon


  • The nuclear option still does not resolve the issue: Safari cannot be enabled.
    Brave and Opera had no problems, Firefox was helped by the nuclear option.
    I mainly use Brave, but airdrop always requires Safari, and some websites require Firefox to be used.



  • @smolk Cookie checks that it has access to the Safari Cookie file:
    ~/Library/Cookies/Cookies.binarycookies

    If that file does not exist, Cookie assumes it does not have Full Disk Access.

    Also some users have found that if when enabling browsers - NOT selecting the Global permissions option, but selecting specific folder helps. If you initially opted to give Cookie Global access, try this:

    • open the Advanced tab in Preferences
    • click the Remove all Sandbox Permissions button.
    • restart Cookie.
    • enable specificities folder permissions for each browser


  • That file did not exist, but files with the same name but a temp ending did. Renaming one did not help.
    But then I deleted all (app, container files) and reinstalled everything from scratch and noticed the file ~/Library/Cookies/Cookies.binarycookies did not exist.
    Thought once, then opened a website in Safari - and the file came into being. I immediately had Safari enabled.
    The file is indeed the crux and it is created by actually using Safari.


Log in to reply