Cookie 5 needs to access this path...

  • Up until a day or two ago the app was working fine, but today when I tried to "Show Cookie 5" from the drop-down menu I got a dialogue/open box saying "Cookie 5 needs to access this path to continue. Click Allow to continue." Clicking Allow dismissed the box for a moment, but then it reappeared. Clicking again and again had the same result. The path was (my identity) iMac/Main Disk/Users/(my user name). I downloaded an update but during the startup process the box appeared again. I've been using this app for quite a while without problem, and don't understand why it has suddenly stopped working. By the way, I'm running my OS (10.12.6) on an external hard drive. That may well have confused things. What path should I select to get things working again?

  • if you can open Preferences - go to the Advanced tab.
    then click the "Remove all Sandbox Permissions" button.

    then restart Cookie.

    if that doesn't work, then you will need to completely reset Cookie, by deleting this folder:

  • @SweetP The first one made no difference. As for the second, there is no folder Containers in the folder Libraries, and a search for com.sweetpprodcutions.Cookie5 returned no results

  • @Schwarzy I had a spelling mistake.... it should be:

    also note that this is in the user Library

  • @SweetP Got it eventually. A couple of app crashes, some unresponsive dialogue boxes and a restart later, everything is now working again. (Although I had to reselect all my favourites manually. Thanks for the quick responses.