Cookie 5 Repeated Crash on Launch



  • So far, I am sad to say, Cookie 5 has been a total disaster. I cannot even open it in El Capitan. There were no specific install instructions/suggestions included with the dmg but I unchecked the ability of vers. 4.5.4 to launch on startup and then I deleted vers 4.5.4 along with its prefs and cache before even trying to run vers. 5.0.3. As soon as I try to launch it it crashes each and every time.

    I attached a TextEdit copy of the last crash.

    Gord



  • Hi Gord,

    Ive fixed some of these crashes in the Beta releases, can you try updating to the latest Beta from the Updates Preference panel, or directly from here:
    https://sweetpproductions.com/products/cookie5/CookieBeta.dmg

    can you let me know if it fixes the crashing
    it should be version 5.0.3.6



  • Thanks for the effort but this version acted the same and immediately crashed. I have attached the crash report.



  • Thanks,
    that crash log was really helpful.
    this version should fix the crash:
    https://sweetpproductions.com/products/cookie5/CookieBeta.dmg

    v5.0.3.7



  • Sorry, no such luck for me. Perhaps there is something specific to my setup that is interfering at the moment. I am attaching the latest crash report but plan to do a Safe Boot and then try again.



  • Sorry, no such luck for me. Perhaps there is something specific to my setup that is interfering at the moment. I am attaching the latest crash report but plan to do a Safe Boot and then try again.

    ok,
    now this version should (fingers crossed) finally fix the crashing.....
    https://sweetpproductions.com/products/cookie5/CookieBeta.dmg

    v5.0.3.8



  • Thanks for sticking with this. Interesting result though. Prior to unzipping the last beta you provided I did a few things:

    Started up in Safe Mode
    Deleted absolutely everything I could find that related to either Cookie 4 or Cookie 5

    That included the folders for vers. 4 and 5 here:

    ~/Library/Containers

    and here:

    ~/Library/Cookies

    along with any and all associated plists, caches and the Cookie Application Support folder.

    I was pleased that Cookie launched once I rebooted after the Safe Boot, although I confess I was rather surprised at how many approvals were required. Does that have to do with SIP?

    Now I notice that I get two different version numbers for the Cookie 5 install. If I check through "About Cookie" from the Menu Bar it displays version 5.0.3.8.

    However, If I "Get Info" on the Cookie app that resides in my Applications Folder I get version 5.0.3.7.

    I attached a couple of screenshots showing those results.



  • Thanks for your patience,
    I'm glad it's finally working!

    The version number will fix itself next time you restart your computer.

    All the approvals are to do with sandboxing... I need to appease the Apple Mac App Store gods and I didn't want 2 versions to support, so sandboxed the trial as well.



  • Ok. I will watch for the correction. Thanks again for sticking with this and getting me going again.

    Gord



  • I restarted just now and was surprised that Cookie asked again for Gatekeeper approval. Do you have any idea why that would not have been remembered between the first install/opening of Cookie 5.0.3.8 yesterday and the restart now?

    Btw, as you informed me, the version numbers were corrected after the restart.

    Gord



  • I need to take a look at sandboxing bookmarks....
    If it happens again,
    You can try resetting the sandbox permissions on the advanced preferences tab.
    Then back in the main window:
    Right click on each browser and disable
    Then enable one at a time, and go through the permissions dialogue agsin.....

    Grrrr sandbox....


Log in to reply