Cookie doesn't see ANY cookies (High Sierra 10.13.6)



  • Cookie (v5.9.2 - App Store) doesn't see ANY cookies, databases, etc. in ANY browser. Zero.

    The app does not seem to have access to the cookies and browser stored data.

    In the app interface I have given Cookie access to the cookie data of each browser, but it doesn't seem to actually give disk access to the relevant folders.

    I have read in this forum about how under MacOS Mojave disk access needs to be given to Cookie in System Preferences. But I am running High Sierra 10.13.6

    Please advice to how to get Cookie 5 working properly again under MacOS High Sierra.



  • go to the Advanced tab in Preferences
    click the Remove all Sandbox Permissions button
    restart Cookie, and then give Cookie access

    does that help



  • That has not helped. After revoking sandbox permissions in the prefs and giving Cookie access to the Users folder (as requested by the prompt) the app still does not see any browser cookies, databases, etc.



  • Cookie only sees browsers if they are located in your Applications folder.

    are your browsers in a custom location?



  • Safari, Chrome, and Firefox are all in the default location (= Applications folder on the root of Macintosh HD). Nothing unusual there.

    P.S. Cookie used to work fine on my machine until recently.



  • I'm having the same problem with Cookie 5.9.2 on High Sierra 10.13.6.

    Cookie only sees Firefox (it does not see Safari), and Cookie does not see any cookies in Firefox. Also, Cookie is not maintaining any cookies for Safari (not surprising since Cookie does not see Safari).

    I reset sandbox permissions as suggested above, but that did not help.



  • This sounds like you need to install the optional scripts to activate Safari:
    https://sweetpproductions.com/products/cookie5/safari.htm

    Also your Firefox settings probably need to be changed to be compatible with Cookie
    https://support.sweetpproductions.com/topic/208/cookie-doesn-t-see-any-firefox-cookies



  • None of the above solutions have worked. Please advise how to get Cookie working again.



  • are the browsers actually showing in the left pane of Cookie?
    have you tried a computer restart.

    you could also try deleting this folder to remove all Cookie's settings, and start with a fresh install:
    ~/Library/Containers/com.sweetpproductions.Cookie5



  • Thank you! Removing the mentioned files from the Library and going through setup once more got Cookie app working properly again.



  • perfect!



  • Adding the optional support scripts has fixed the Safari issue I was seeing. Usually the install of Cookie walks me through that; it didn't this time for some reason (I recently reinstalled my computer). I've been taking notes on how I did my reinstall and will add a comment about the support scripts to those notes.



  • @eagle I had to remove the instructions on Mac App Store version...
    😞

    Cookie is not passing review when I have the instructions enabled.
    🤷