Enabling Cookie5 on macOS Mojave (10.14)



  • Its actually really easy but not super obvious to to get Cookie running on Mojave.

    1. Open System Preferences
    2. Open the Security & Privacy tab
    3. Open the Privacy tab
      4. Open the Application Data section
    4. Open the Full Disk Access section
    5. Add Cookie

    🙂



  • There is no "Application Data section" (step 4) on macOS 10.14 (18A365a). Instead there is a folder called "Full Disk Access". Could it be that Apple replcade Application Data with "Full Disk Access" on the latest Beta version of Mojave?



  • ah yes,
    you're right, it has been renamed
    🙂



  • Thanks Russell

    Cookie 5 now running in Mojave ? (just had to remember to click on the padlock to unlock the Privacy pane before adding Cookie 5)

    Dave



  • Im working on a Dark Mode theme now,
    and will put some kind of notification in to enable this in System Preferences



  • No problems running Cookie on my High Sierra iMac, but can not get it to run on my iMac running Mojave. I’ve granted it full disc access and installed the three scripts.

    Irritatingly the notification from Cookie tells me that cookies have been cleared – but a glance at Safari >Privacy shows they are all still there. Anyone tell me what’s going wrong ?



  • Are you running the latest App Store version?
    Because the App Store version is not yet completely Mojave compatiable. And Apple is taking their time reviewing v5.9.1....
    The version from my store should be working.

    V5.9.1 is the Mojave compatible version.



  • Yes I am, all is explained. I’ll download the trial version and hope Apple pull their finger out in the next 14 days.

    Appreciate swift response.

    Jack



  • v5.9.2 is finally in the Mac App Store
    🙂



  • I successfully followed the instructions here. Safari does not appear in the browsers list on the left side of the Cookie window. I checked the Safari box on install. How do I add Safari to the list of Browsers?



  • if you hover over the Disabled text at the bottom,
    Show should appear,
    click on that to reveal Safari and you should be able to enable it



  • @SweetP It is notworking for me! Everytime i login to my computer i'll get the remark to authorize although i have Cookie added.



  • @gkruijer this is so much more difficult than it needs to be. But that is an issue with macOS, Cookie is only reporting what the system tells it.... 😞

    make sure that:

    1. Cookie is in your applications folder
    2. There are no other copies of Cookie on your computer
    3. Move the Cookie5.dmg file to the trash

    Then:

    1. Remove Cookie from System Preferences
    2. Drag & Drop Cookie (from your Applications folder) into the Full Disk Access window in System Preferences
    3. Maybe also Restart your computer


  • I have tried all the above multiple times, including deleting full disk access and re adding it. No matter what I do, I still cannot enable Safari in Cookie 5.9.4. I've tried quitting Safari, Cookie, rebooting, everything I can think of, but to no avail! Any other suggestions?

    Thanks,
    Jack



  • are you adding Cookie to the list via drag and drop from the Applications folder?



  • I have the exact same problem but with Privatus, not matter what I do Safari is just not working with Privatus.



  • @SweetP Hi Russell, I have tried it both by dragging and dropping and with the "+" button, all to no avail. Help?
    Jack



  • Does the Cookie file exist?
    ~/Library/Cookies/Cookies.binaryCookies



  • No... odd?



  • thats where Safari stores its cookies, and also the file Cookie checks against to make sure it has system access.

    are you using another cookie app, which may be deleting that file?