Cannot install Helper (SweetP Store version)

  • I've just received a notification and updated from v3.0.6 to v3.0.7

    I am unable to complete the update by installing the helper. I get the "Please Read Me" link. I click through to get the "WiFiSpoofXPCService is trying to install a new helper tool." I enter my password.

    And nothing happens. The "Please Read Me" link does not go away.

    I tried quitting.
    I tried restarting.

    When I go to /Library/PrivilegedHelperTools/sweetpproductions.WiFiSpoofHelperTool it shows a modification date of last month (when I first installed WiFiSpoof on this Mac).

    Ideas on how to get the Helper installed? Thanks!

  • Well, I solved my own problem. I ran these terminal commands to uninstall.

    sudo launchctl unload /Library/LaunchDaemons/com.sweetpproductions.WiFiSpoofHelperTool.plist
    sudo rm /Library/LaunchDaemons/com.sweetpproductions.WiFiSpoofHelperTool.plist
    sudo rm /Library/PrivilegedHelperTools/com.sweetpproductions.WiFiSpoofHelperTool sudo security -q authorizationdb remove "com.sweetpproductions.WiFiSpoof.changeAddress"

    Then I installed a fresh copy, ran the install helper and it worked.

  • perfect!