Cookie Started Quitting



  • Beginning yesterday, Cookie began to suddenly quit even with no interaction with it. Prior to that (for more than a couple weeks), I did notice it was slow to respond when I click on it from menu (the top right items I have automatically launching). There would be a pause before it would show the drop down menu. Now, it is quitting suddenly. Below is the report. Hope it helps to figure out the issue.

    Process:         Cookie [957]
    Path:            /Applications/system health/Cookie.app/Contents/MacOS/Cookie
    Identifier:      com.sweetpproductions.Cookie
    Version:         3.0.11 (3.0.11)
    Code Type:       X86-64 (Native)
    Parent Process:  launchd [164]
    User ID:         501
    
    Date/Time:       2013-02-12 11:05:12.826 -0500
    OS Version:      Mac OS X 10.8.2 (12C60)
    Report Version:  10
    
    Interval Since Last Report:          5815329 sec
    Crashes Since Last Report:           807
    Per-App Interval Since Last Report:  28752 sec
    Per-App Crashes Since Last Report:   7
    Anonymous UUID:                      7DCA54A8-EC09-154D-BBCB-9EF050659837
    
    Crashed Thread:  0  Dispatch queue: com.apple.main-thread
    
    Exception Type:  EXC_BAD_ACCESS (SIGSEGV)
    Exception Codes: EXC_I386_GPFLT
    
    Application Specific Information:
    objc_msgSend() selector name: retain```


  • is this the version from my server, or the Mac App Store version?



  • From your server. I was alerted that an upgrade was available either yesterday or day before. I upgraded thinking that would fix the issue, but it didn't.



  • ok, thanks. ill look into this right now.



  • Can you give this version a try and see if it fixes your crashing problem:
    http://sweetpproductions.com/products/cookie/Cookie3011a.zip



  • While I'm waiting to see if it continues to quit, let me add some things. I've already mentioned the delay when clicking on it to get the menu. Is it sensitive to what folder it's in? Must it be in the main Applications folder to work properly? I keep it in a folder with similar applications. That folder resides inside the applications folder.

    Also, I notice that when I quit it on my own, it is delayed; then, it quits with the error message saying it unexpectedly quit. I thought it was just a one time thing, so I opened it and quit it five more times. Each time I quit it, the error message pops up saying it unexpectedly quit, with the option to review the report. So even when I quit it on my own, it still isn't doing a proper quit. Instead, it is behaving as though it force quit on its own.

    This is happening with the version you sent as well. I just tested it. So far, it hasn't quit on its own yet. But when I quit with your version, it does the same thing described above.



  • do you get any Cookie related error messages in:
    Applications/Utilities/Console.app



  • Under User Diagonostics in the Console, there are 9 messages.



  • could you copy & paste them in this thread, and i'll see if I can find what the problem is



  • It just quit again about 3 minutes ago on its own. I did not interact with it all day.

    This is the corresponding crash report.

    Process:         Cookie [325]
    Path:            /Applications/system health/Cookie.app/Contents/MacOS/Cookie
    Identifier:      com.sweetpproductions.Cookie
    Version:         3.0.11 (3.0.11)
    Code Type:       X86-64 (Native)
    Parent Process:  launchd [165]
    User ID:         501
    
    Date/Time:       2013-02-13 19:49:07.536 -0500
    OS Version:      Mac OS X 10.8.2 (12C60)
    Report Version:  10
    
    Crashed Thread:  0  Dispatch queue: com.apple.main-thread
    
    Exception Type:  EXC_BAD_ACCESS (SIGSEGV)
    Exception Codes: EXC_I386_GPFLT
    
    Application Specific Information:
    objc_msgSend() selector name: retain```


  • This looks like the same version.

    did you replace your original version, with the one from the d/l?
    the new one should be version 3.0.11a

    Process: Cookie [996]
    Path: /Applications/system health/Cookie.app/Contents/MacOS/Cookie
    Identifier: com.sweetpproductions.Cookie
    Version: 3.0.11 (3.0.11)
    


  • Yes I did. Let me make sure it's opening the right one. I didn't delete the other one.
    [hr]
    Ok. I've made sure it is now opening the correct one. I deleted the old one from my system to make sure. I'll keep you posted.



  • perfect,

    let me know how it goes.



  • It continues to quit on its own.

    Process:         Cookie [610]
    Path:            /Applications/Cookie 3011a.app/Contents/MacOS/Cookie
    Identifier:      com.sweetpproductions.Cookie
    Version:         3.0.11a (3.0.11a)
    Code Type:       X86-64 (Native)
    Parent Process:  launchd [165]
    User ID:         501
    
    Date/Time:       2013-02-14 18:33:10.029 -0500
    OS Version:      Mac OS X 10.8.2 (12C60)
    Report Version:  10
    
    Crashed Thread:  0  Dispatch queue: com.apple.main-thread
    
    Exception Type:  EXC_BAD_ACCESS (SIGSEGV)
    Exception Codes: EXC_I386_GPFLT
    
    Application Specific Information:
    objc_msgSend() selector name: retain```


  • sorry for the delay,

    Ive been travelling with my son for the past week. Ill be home monday, and ill take a look at it then.



  • Not a problem.







  • This should fix the crashing, so you can at least have Cookie functioning:
    http://sweetpproductions.com/products/cookie/Cookie3011e.zip

    there are two bugs i still need to fix however, so it is not the final build:
    -if you try to use the "Remove" button for domains enclosed in a folder (with the triangle displayed) Cookie will not respond
    -I also need to group the display of similar domains

    I should get these two bugs fixed up tonight.



  • Heres the pre-release version of 3.0.12
    Iv'e submitted it to Apple, so maybe by the end of the week it will be available on the MAS.
    http://sweetpproductions.com/products/cookie/Cookie3012.dmg


Log in to reply