• I spoke too soon. Less than 24 hours after reinstalling Cookie 5, Cookie once again gets stuck on Any more suggestions?

  • ok try this:
    navigate to the Applications Script folder
    ~/Library/Application Scripts/com.sweetpproductions.Cookie5

    then open
    type cd then drag the scripts folder onto the terminal, and press RETURN
    then type these 3 commands, each followed by pressing RETURN:

    chown :staff
    chown :staff
    chown :staff

    also the extra scripts are only needed if you have Safari Technology Preview Installed.
    can you let me know if that works

  • That seems to have done the trick. I can quit safari and Cookie empties the cache without any problem.
    The chown command changed

    [email protected] 1 ronaldgold  admin   47 Feb  7  2016
    [email protected] 1 ronaldgold  admin  119 Nov 18 08:04
    [email protected] 1 ronaldgold  admin  159 Feb  7  2016


    [email protected] 1 ronaldgold  staff   47 Nov 18 08:04
    [email protected] 1 ronaldgold  staff  119 Nov 18 08:04
    [email protected] 1 ronaldgold  staff  159 Nov 18 08:04

  • perfect!
    im not sure why they are installing with the wrong permissions to begin with,
    but thats great its a simple fix.

  • I deleted Cookie and all associated files and scripts, reinstalled and still experienced the endless process. I then searched the forum and found your "chown " workaround which did the trick. Hopefully this is a temporary fix to be corrected in some future release, yes?

  • perfect,

    Im not sure why the files are installed with the wrong permissions. but ill look into it.

  • The endless process has returned despite changing permissions as you described previously. Permissions are:

    [email protected] 1 cj  staff   47 Nov 18 08:04
    [email protected] 1 cj  staff  119 Nov 18 08:04
    [email protected] 1 cj  staff  159 Nov 18 08:04

    Even with Safari quit if I run Cookie and then quit Cookie the endless process returns. I have removed Cookie from StartUp Items for the time being in the hope you can find a permanent solution to this problem.

  • are you using the Mac App Store, or the version from my store @pumpkin?

  • Purchase directly from you april 30, 2016. Order #27069. Current rev 5.2.1.

  • have you tried a computer restart?
    that can sometimes fix strange issues like this

  • Not wanting to jinx anything but I did a reboot and so far all is well!

  • I have got the same problem and found a solution: Change the script from

    find /private/var/folders \! -name "*SafariTechnologyPreview*" -name "**" -exec rm -r {} \;


    find /private/var/folders \! -name "*SafariTechnologyPreview*" -name "**" -exec rm -r {} \; 2>/dev/null

    Because the original script throws "Permission denied" errors and therefore opens the file descriptor stderr, it seems that the parent process ( can't close it as long as a file is open.

  • Thanks ralf!

    I'll update the script to your solution.

Log in to reply