Keeps asking for access to preferences



  • Cookie 5 keeps asking for access to my ~{user}/Library/Preferences path whenever I click on the Cookie menu in the desktop menu. I click Allow and both the window and menu go away but the same thing repeats when I try opening the menu again.

    Cookie 5.0.3, Mac OS X 10.11.4



  • I have the same issue. "cookie needs to access this path to continue" dialog box pops up after startup asking for access to Macromedia folder, have to click 'OK' 17 times or so to resolve, Cancel does not stick. Allowing computer to sit for several minutes usually resolves it on its own. Issue occurs with same user on two different Macs. Has been happening for a few weeks now.

    Cookie 5.0.3, Mac OSX 10.11.4



  • Try the beta out guys,
    The sandboxing is a real nightmare....
    I'm debating getting rid of it.....

    https://sweetpproductions.com/products/cookie5/CookieBeta.dmg



  • Thanks, the beta appears to have worked, cruising along on both machines fine today, no more access popups.
    Cheers.



  • The Beta worked for me also.

    Thank you



  • That's great!



  • Hi,

    Both the beta and the new current version 5.0.4 still asks for permission. Window after window...it does not stop. I have to use Activity Monitor to quit the program.

    I'm using El Capitan.



  • Try this:

    • Disable the timer
    • Open preferences and go to the Advanced tab
    • Click the "Remove all Sandbox Permissions" button
    • Go back to the main window
    • Disable a browser(any browser it doesn't matter which)
    • Re-enable the browser
    • Give permission (there should be only 1 window that appears)

    Can you let me know if this works for you.

    I changed permissions in v5.0.4 to give Cookie more permissive permissions, but it does not set the new permissions unless you enable a new browser. Perhaps I should prompt for the new permissions in an update...



  • Russell,

    It seems the permissions windows are dimming out the Cookie options in the menubar. I can't access menu options.



  • you can force quit Cookie from /Applications/Utilities/Activity Monitor
    then delete this file:
    ~/Library/Containers/com.sweetpproductions.Cookie5

    after doing this you will need to run through the setup process again.



  • I got it fixed.

    I deleted Cookie 5.0.4 with CleanApp and installed version 5.0.5 before I read your last post.

    Thanks...



  • That's great!