• Hi.

    I just reinstalled my iMac (2011, High Sierra), and now I find that Cookie 5 never completes a "Remove" procedure. I have Cookie 5 set to remove cookies when I quit a browser, and with the Cookie 5 window up, I do see the spinner start a second or so after I quit Safari -- however, the cookies are never deleted and the spinner never stops.

    I do have the helper scripts installed. I have restarted the computer, run the "Remove all sandbox permissions" procedure, and I have tried manual cookie removals. In no case does Cookie 5 complete the removal process.

    This is new, because the previous install worked just fine (there were other things that didn't work, and those are the reason for my system rebuild).

    What else should I try? Thanks.

  • strange, have you tried a restart of Cookie?

  • Hello.

    I am having the same issue on my Late 2011 iMac running High Sierra 10.13.6 and Cookie 5.12. Helper scripts have been installed.


  • @SweetP Hi, Russell, yes, I have restarted Cookie and the computer.

  • Are you using Cookie in an administrator account?

  • This may also be a permissions issue with your scripts:

    You could try this:
    navigate to the Applications Script folder
    ~/Library/Application Scripts/com.sweetpproductions.Cookie5

    then open Terminal.app
    type cd then drag the scripts folder onto the terminal, and press RETURN
    then type these 3 commands, each followed by pressing RETURN:

    chown :staff clearCookies.sh
    chown :staff clearSafariCache.sh
    chown :staff clearSafariHistory.sh

  • I was having problems with 5 going slow. Now I have upgraded to 6 - I am on a late '13 MBP current and 6 works flawlessly. I use it all the time including reading news sites that have a 5 free views / paywall per month.

    6 =- fast and flawless. I have ben using cookie for 10+ years. thanks

  • @SweetP Hi, yes, I'm using Cookie 5 in an administrator account, and the script files are all owned by my user and group staff. They weren't all executable, though, and it turns out that that was the problem. I have set the scripts executiable ("chmod 755 ~/Library/Application\ Scripts/com.sweetpproductions.Cookie5/*") and now it works. Thanks.

  • @eagle Thank you very much. Cookie 5 suddenly stopped working (never finished its tasks) with Safari and I tried everything. Only your solution was able to make it work again.

  • @zincker perfect