Cookie 6 not recognizing "Full disk Access"



  • after giving Cookie 6 'full access' had to reboot my computer to get Safari accepted (not just restart Cookie)



  • Similar issues here. Firefox and Chrome got added with no problem, but Safari kept asking me to grant full disk access no matter how many times I did so. I restarted as LEoM suggested. Clicking for Safari access then produced a prolonged spinning beachball, but one that did resolve itself and it seems to be working now.



  • for everyone still with issues,
    here is the nuclear option, which may help:

    A full reset:

    • Move Cookie 5 to the trash
    • Export your favourites using the small heart icon in the bottom right of the “Websites” tab
    • Quit Cookie
    • Remove Cookie, and Cookie 5 from System Preferences (Full Disk Access)
    • Delete this folder: ~/Library/Contaniers/com.sweetpproductions.cookieapp
    • Restart your computer
    • Then open Cookie,and run through the setup again.
    • import your favorites back in using the same heart icon

    Also Note:
    Cookie looks for the existence of the
    ~/Library/Cookies/Cookies.binaryCookies

    If you don’t have the file on your system, Cookie thinks it doesn’t have dull disk access. If you have just installed your Operating System, or have never run Safari in regular NON private browsing mode. It won’t exist, and you will need to open Safari in NON private browsing mode and visit a few websites to generate the file.



  • The nuclear option still does not resolve the issue: Safari cannot be enabled.
    Brave and Opera had no problems, Firefox was helped by the nuclear option.
    I mainly use Brave, but airdrop always requires Safari, and some websites require Firefox to be used.



  • @smolk Cookie checks that it has access to the Safari Cookie file:
    ~/Library/Cookies/Cookies.binarycookies

    Also some users have found that if when enabling browsers - NOT selecting the Global permissions option, but selecting specific folder helps. If you initially opted to give Cookie Global access, try this:

    • open the Advanced tab in Preferences
    • click the Remove all Sandbox Permissions button.
    • restart Cookie.
    • enable specific folder permissions for each browser


  • That file did not exist, but files with the same name but a temp ending did. Renaming one did not help.
    But then I deleted all (app, container files) and reinstalled everything from scratch and noticed the file ~/Library/Cookies/Cookies.binarycookies did not exist.
    Thought once, then opened a website in Safari - and the file came into being. I immediately had Safari enabled.
    The file is indeed the crux and it is created by actually using Safari.



  • I continue to struggle with granting Cookie "Full Disk Access". No matter how many times I go through the process, I continue to get the attached error message when I launch the Cookie interface. Please advise. Thank you.
    Screen Shot 2019-12-15 at 12.36.24.png

    Cookie v6.0.7
    macOS 10.15.2 (19C57)



  • Do you always run Safari in Private browsing mode? If so, then the Cookies.binaryCookies file most likely does not exist.

    Another thing to consider - Cookie does need to be in the Applications folder.



  • @SweetP Thank you for your reply.

    Safari is never in private mode.
    Cookie.app is in /Applications.

    Where should Cookies.binaryCookies be located? I cannot find it anywhere.



  • @HFTobeason it should be here:

    ~/Library/Cookies/Cookies.binarycookies
    

    The ~ means it is in you user folder, which you can access like so:
    http://osxdaily.com/2016/12/12/show-user-library-folder-macos-sierra/



  • @SweetP This worked for me.



  • @UncleFuzzy great!



  • @LEoM I restarted with no luck. Stuck in an infinite loop trying to "Enable" for Safari.



  • I had this problem after initially upgrading to Cookie6 but it was resolved.

    BUT NOW, after allowing AppStore to upgrade me to 6.0.12, I am back in the loop of having to grant access.
    System level is macOS 10.15.3
    Cookie does have full disk access. I have quit Cookie, removed disk access, restarted system. Doesn't help.
    I have had to disable Cookie to get ANY work done.



  • @StuFried does the cookie file exist?

    ~/Library/Cookies/Cookies.binarycookies
    


  • @SweetP Yes it does. But it has a creation date of today. Unless it is destroyed at browser quit I would have expected it to have an older creation date



  • @SweetP Its been 4 days since I answered your question. Any ideas?



  • @SweetP Hey @SweetP,
    Wanted to update that I stopped the app, removed the permissions, removed application (using AppCleaner), restarted my computer, downloaded the app from the App Store.
    Now I can not even enable Safari (Firefox and Chrome are OK), and it STILL does not recognize that it has "Full Disk Access" granted



  • @StuFried are you running Safari in private browsing mode?


Log in to reply